Handshake Supported Browsers (for Employers)

Tawnya -

For the best Handshake experience possible, we support all browser versions released within 6 months. Below is a list of browsers that are supported: 

Please note that we no longer support Internet Explorer V10. If you are on V10 or below, you'll see the following error appear: "It looks like your browser is out of date and not fully supported. This may cause Handshake to work improperly. We recommend updating your browser for a better experience and improved security."

image__10_.png

Whatever browser you choose to use, we recommend updating it when a new version comes out, as updates often include important performance and security fixes.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request